All iPads Need to be Updated!

Go to Settings and check for Software Update.  All iPads must be on version 10.2.1 for SOL testing.  In addition, the latest version will also resolve issues with IXL and other apps.

The TestNav app should have automatically installed on your iPad.  If you don’t see it, check the App Catalog.

See Teri if you have any problems.